Cotonti / Open Source PHP Content Management FrameworkContent Management Framework

Forums / Cotonti / Extensions / Support / Steam module

Kingsley
#1 2012-10-24 14:59

During configuration the following pops up:

 

Warning: file_get_contents() [function.file-get-contents]: http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/p57943/domains/fap-clan.com/public_html/modules/steam/lib/steam/SteamGame.php on line 81

Warning: file_get_contents(http://api.steampowered.com/ISteamUserStats/GetSchemaForGame/v0002/?key=&appid=71270&l=en) [function.file-get-contents]: failed to open stream: no suitable wrapper could be found in /home/p57943/domains/fap-clan.com/public_html/modules/steam/lib/steam/SteamGame.php on line 81

Warning: Invalid argument supplied for foreach() in /home/p57943/domains/fap-clan.com/public_html/modules/steam/inc/steam.functions.php on line 252


Thought it to be something you wanted to know, Trustmaster..

 

btw, the module does function, it only gives those errors while configuring..


This post was edited by Kingsley (2012-10-24 15:09, 8 years ago)
Trustmaster
#2 2012-10-24 16:16

Well, as it tells you allow_url_fopen is disabled on your host so the module can't fetch remote data from Steam API/Community. It can be modified to use cURL instead of url fopen.

May the Source be with you!
Kingsley
#3 2012-10-24 17:00

No idea what u r talking about php aint my thing.... so I guess it's only me who has this.. Delete topic plz.

Trustmaster
#4 2012-10-24 20:10

No, it's not you, it's some of the hostings which will cause this problem. So we need to solve it for you and for others.

Added 18 hours later:

Please update the module, I've added cURL support so it should now fetch stuff on your host.

May the Source be with you!

This post was edited by Trustmaster (2012-10-25 13:56, 8 years ago)
Kingsley
#5 2012-10-25 15:29

rgr that.. and thank you for the quick fix :)

 

Added 6 minutes later:

Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in /home/p57943/domains/fap-clan.com/public_html/modules/steam/lib/steam/SteamUtility.php on line 38

Warning: Invalid argument supplied for foreach() in /home/p57943/domains/fap-clan.com/public_html/modules/steam/inc/steam.functions.php on line 252

with a new/fresh install


This post was edited by Kingsley (2012-10-25 15:34, 8 years ago)
Trustmaster
#6 2012-10-25 18:37

Your hosting is so strict, I had to make another patch for it :) Please retry ;)

May the Source be with you!
Kingsley
#7 2012-10-25 18:48

thank you, now installed without a warning :)

 

GHengeveld
#8 2012-10-26 07:18

What was the solution? I normally use cURL for these things (hardly ever file_get_contents), so I'm wondering what would fix curl_setopt(). I've had open_basedir errors myself in the past, but never really understood what caused it.

Trustmaster
#9 2012-10-26 12:53

I chose the simple path: just disabled CURLOPT_FOLLOWLOCATION option because it isn't really needed in this module. Mimicking it in general would mean checking for redirect responses and handling them manually.

May the Source be with you!