Форуми / Cotonti / Bugs / Reports / Bug in user list with genoa 0.6.13

foxhound
#1 06.02.2011 17:43
This issue exists in earlier versions as well as I have met this issue a long time ago as well but never understood why it happened (I thought it was a prob with maybe my DB).

When a user registrates on your website and in his name he adds a "+" sign you can not acces his profile when going through the users list. Check here for yourself:
http://www.armaholic.com/users.php?f=_&s=name&w=asc&d=50

Almost at the bottom you can find 2 people with a "+" in their name and you can not acces their profile.
You can check their user id and navigate directly to that user though. But not from the list.
Also when you click the username on their profile (title) you get an error.

If I remove any "+" sign in such a name all works like it should.


I thought you might want to know, maybe you can fix it in a genoa update if you planned one (as far as I know you didn't unless there was a security issue which this is not). So, maybe check if the problem is gone in Sienna?



@devs
If you do not want to register on my site to be able to acces the userlist just let me know and I will create a test account for you!!
<img src="http://www.armaholic.com/datas/thumbs/green-sea-battalion-uniforms-version-03-preview_4.jpg" alt="green-sea-battalion-uniforms-version-03-" />
pieter
#2 06.02.2011 19:09
In Sienna it is the same.
I get:
Fatal error : SQL error 42000: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'LIMIT 1' at line 1
... can we help you ...
Trustmaster
#3 07.02.2011 01:12
I confirm this bug, it is related with the problem in sed_url/parse_str which we have recently encountered. It will be solved in 0.6.14/0.9.0. For now, try this replacement of function sed_build_user() in system/functions.php (Genoa only):
function sed_build_user($id, $user)
{
	global $cfg;

	if($id == 0 && !empty($user))
	{
		return $user;
	}
	elseif($id == 0)
	{
		return '';
	}
	else
	{
		return (!empty($user)) ? '<a href="'.sed_url('users', array('m' => 'details', 'id' => $id, 'u' => $user)).'">'.$user.'</a>' : '?';
	}
}


Added 7 minutes later:

Ticket #600 created. Thanks for the report!
May the Source be with you!

Відредаговано: Trustmaster (07.02.2011 01:20, 13 років тому)
jslowik
#4 11.04.2011 15:25

Perhaps a similar error?

Is anyone else seeing this, or is it just me?

 

Fatal error : SQL error : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1


Відредаговано: jslowik (11.04.2011 15:43, 13 років тому)
Trustmaster
#5 11.04.2011 18:44

If you turn debug mode on in your datas/config.php then it will show the source of the error.

May the Source be with you!
jslowik
#6 25.04.2011 16:05

I'm sure this is something dumb. Please excuse my very minimal skills sad

 

#0  sed_diefatal(SQL error : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1) called at [/home1/jslowikc/public_html/fundraising/system/database.mysql.php:219]
#1  sed_sql_query(SELECT * FROM sed_users  WHERE 1 ORDER BY user_name asc LIMIT 0,) called at [/home1/jslowikc/public_html/fundraising/system/core/users/users.inc.php:155]
#2  require_once(/home1/jslowikc/public_html/fundraising/system/core/users/users.inc.php) called at [/home1/jslowikc/public_html/fundraising/users.php:53]


Відредаговано: jslowik (25.04.2011 16:22, 12 років тому)
Trustmaster
#7 25.04.2011 18:01

Seems like maxusersperpage configuration option is missing from sed_config table. Please check if Admin => Configuration => Users => "Maximum lines in userlist" exists. If for some strange reason it doesn't then you might need to run this SQL query to restore it:

INSERT INTO `sed_config` (`config_owner`, `config_cat`, `config_order`, `config_name`, `config_type`, `config_value`, `config_default`, `config_text`) VALUES
('core', 'users', '05', 'maxusersperpage', 2, '50', '', '');

 

May the Source be with you!
jslowik
#8 25.04.2011 22:57

It definitely exists. Was set to five. Set it to the max available value and error is gone! Much appreciated.

For my own benefit what would have caused this? Server issue? If it's too complex to explain I quite understand. Thanks again!