Cotonti / Open Source PHP Content Management FrameworkContent Management Framework

Forumlar / Cotonti / Support / Version 0.9.11 Header log in

I can't log in via the header

musashi9
#1 2012-09-24 02:21

I just can't log in from the header, when I try it looks like it is going ot log in but I just end up as a guest. I have to use login.php

My contonti version is 0.9.11

Here is the code fro mthe header.tpl

        <!-- BEGIN: GUEST -->
                <li>
                    <div class="menu_button"><a href="#login" name="modal">{PHP.L.Login}</a></div>
                </li>
<!--<li><div class="menu_button"><a href="{PHP|cot_url('login')}">{PHP.L.Login}</a></div></li>
<li><div class="menu_button"><a href="{PHP|cot_url('users','m=register')}">{PHP.L.Register}</a></div></li>
<li><div class="menu_button"><a href="{PHP|cot_url('users','m=passrecover')}">{PHP.themelang.header.Lostyourpassword}</a></div></li>-->

                <li>
                    <div id="login" class="window">
                    <div class="login_form_header"></div>
                    <div class="login_form_body">
                        <form name="login_form" action="{PHP|cot_url('login','a=check')}" method="post">
                            <input type="text" class="tinput" name="rusername" size="13" maxlength="32" value="{PHP.themelang.header.Login}" onblur="if(this.value=='') this.value='{PHP.themelang.header.Login}';" onfocus="if(this.value=='{PHP.themelang.header.Login}') this.value='';" />
                            <input type="password" class="tinput" name="rpassword" size="13" maxlength="32" value="{PHP.L.Password}" onblur="if(this.value=='') this.value='{PHP.L.Password}';" onfocus="if(this.value=='{PHP.L.Password}') this.value='';" />
                            <input type="hidden" name="rremember" value="1"/>
                            <input class="login_submit" type="submit" value="{PHP.L.Login}" />
                        </form>

                        <div class="login_footer">
                            <a href="{PHP|cot_url('users','m=register')}">{PHP.L.Register}</a>
                            <a href="{PHP|cot_url('users','m=passrecover')}">{PHP.themelang.header.Lostyourpassword}</a>
                        </div>
                    </div>
                    <div class="login_form_footer"></div>

Trustmaster
#2 2012-09-24 05:04

I can't see anything wrong with this form. What is your form code in login.tpl then?

May the Source be with you!
musashi9
#3 2012-09-24 05:32

login.php

 

<!-- BEGIN: MAIN -->
    <div id="container">
        <div id="trd_box_header">
            <h2>{USERS_AUTH_TITLE}</h2>
        </div>

        <div id="trd_box_body">
            <div id="full_width_table">
                <!-- BEGIN: USERS_AUTH_MAINTENANCE -->
                <div class="maintenance">
                    <p>{PHP.themelang.usersauth.Maintenance}<br>
                    <strong>{PHP.themelang.usersauth.Maintenancereason}: {USERS_AUTH_MAINTENANCERES}</strong></p>
                </div>
                <!-- END: USERS_AUTH_MAINTENANCE -->

            <form name="login" action="{USERS_AUTH_SEND}" method="post">
                <table id="users_table" border="0" cellspacing="1" cellpadding="2">
                    <tr>
                        <td>{PHP.L.Username}: {USERS_AUTH_USER}</td>
                        <td rowspan="3"><a href="{USERS_AUTH_REGISTER}">{PHP.L.Register}</a></td>
                    </tr>

                    <tr>
                        <td>{PHP.L.Password}: {USERS_AUTH_PASSWORD}</td>
                    </tr>

                    <tr>
                        <td rowspan="2">{PHP.themelang.usersauth.Rememberme}: {PHP.out.guest_cookiettl}</td>
                    </tr>

                    <tr>
                        <td rowspan="2"><a href="/plug.php?e=passrecover">{PHP.themelang.usersauth.Lostpassword}</a></td>
                    </tr>

                    <tr>
                        <td class="valid"><input class="fw_button" type="submit" value="{PHP.L.Login}" /></td>
                    </tr>
                </table>
            </form>

            </div>
        </div>
        <div id="trd_body_footer"></div>
    </div>

<div class="clear"></div>
<!-- END: MAIN -->

pieter
#4 2012-09-24 06:28

Does everybody has this, or only you? 
All browsers?

... can we help you ...
musashi9
#5 2012-09-24 06:57

I tested it in the latest FireFox, Chrome, IE. all same results

Using themses veronese and symisun-03

Nemesis has no header log in

If I try and log in via the header with bogus information then it redirects me to the error page, so it is accepting some data.


Bu konu musashi9 tarafından düzenlendi(2012-09-24 07:08, 10 yıllar önce)
Twiebie
#6 2012-09-25 00:40

Just tried it with the latest version of Cotonti and the Symisun-03 theme. It works fine for me.

Did you try to clear Cotonti's cache?

musashi9
#7 2012-09-25 00:49

I just cleared the Internal Cahce and the Disk Cache, still no luck.

Twiebie
#8 2012-09-25 00:51

Just for testing, try a completely fresh installation with the latest version of Siena.

Either on your localhost or a different server.

musashi9
#9 2012-09-25 01:07

hmm I changed some things like Consildate header footer resources and force remember me and now I cant log in a t all

Added 31 minutes later:

I reinstalled a backup I had and now I am back with just the header log in problem

I will try a fresh install too to see if that works.

Added 1 hours later:

I did a complete fresh install to a new folder and I can use header log in without any problems

Added 5 minutes later:

Ok I went back to my original non working setup and went into amin-main-config and just reset everything I could and now it works.

 


Bu konu musashi9 tarafından düzenlendi(2012-09-25 04:00, 10 yıllar önce)
Twiebie
#10 2012-09-25 09:53

Good to hear it works now, I guess we'll never know what caused it. :)

musashi9
#11 2012-09-25 10:29

Indeed! Thanks for the help