Cotonti / Open Source PHP Content Management FrameworkContent Management Framework

Форумы / Cotonti / Extensions / Twitter plugin by esclkm (update)

tensh
#1 07.10.2013 10:34

http://www.cotonti.com/extensions/community-social/twitterbot

I've updated this plugin to work with newest php class so that we can connect with twitter's newest API 1.1 - the old one got deprecated on march 2013.
http://www.cotonti.com/datas/users/twitter_253.zip

Usage (because there's no proper Readme):

1. Sign in to the http://twitter.com and register an application from the http://dev.twitter.com/apps page. Click on Create My Access Token link and retrieve your own access token. Now you have consumer key, consumer secret, access token and access token secret. BTW, Your app should have read&write permissions.
2. Install plugin and put the data above in Plugin settings.
3. Place {TWITTER} tag in index.tpl
4. Place {TWITTER_TEXT} tag in page.add.tpl
5. Enjoy

Attention - I didn't test adding tweets together with adding pages - please test and report if it's working.

I just did little work to update it, no copyright taken and so on. Hope that nobody gets offended :) When autor updates his plugin in his repository and on his website, I might just delete this post.

Twiebie
#2 07.10.2013 14:14

Cool tensh, I'll try that out.

Trustmaster
#3 07.10.2013 14:46

Thanks a lot! I've updated the original page to link to your version and added usage there.

May the Source be with you!
esclkm
#4 07.10.2013 17:54
Thanks
littledev.ru - мой маленький зарождающийся блог о котонти.
снижение стоимости программирования и снижение стоимости производства разные вещи. Первое можно скорее сравнить с раздачей работникам дешевых инструментов, чем со снижением зарплаты
Chiaroscuro
#5 11.02.2014 06:15

После обновления:

Fatal error: Uncaught exception 'TwitterException' with message 'Server error #403'

Добавлено 3 часа спустя:

Нашел баг, обновите файлы от сюда https://github.com/dg/twitter-php

OAuth.php

twitter.class.php


Отредактировано: Chiaroscuro (11.02.2014 09:03, 7 лет назад)
tensh
#6 06.03.2014 08:22

Yeah, recently there was another update on Twitter which made this plugin unusable for a while, now the author of the classes made neccessary changes so that we can use it again :)

musashi9
#7 07.03.2014 08:18

I just realised my twitter plugin stopped sending tweets in 2012 so I installed this update but my plugin still says v1.0 ? and it fails to send new tweets ?

Everything with the keys is set up.

 


Отредактировано: musashi9 (07.03.2014 22:55, 7 лет назад)