Cotonti / Open Source PHP Content Management FrameworkContent Management Framework

Форумы / Cotonti / General / Markitup requirements

Server requirements to run this plugin?

haselyn
#1 20.06.2009 00:22
Interestingly, the Markitup editor works fine on my local website, but the remote version online it just shows a standard text box with none of the controls.

I was wondering if there's any particular things that need to be enabled on the server for this plugin to work, since the files are the same and the settings are the same for the plugin on the remote site.
Kingsley
#2 20.06.2009 02:32
This problem exsists on one of my webbie to, and then only in IE. First it worked, now it doesn't.. :(
Trustmaster
#3 20.06.2009 19:01
There are no special requirements for the server. But this problem appears from times to times because of Firewall software or something. What browsers does your problem affect? Could you test on some other computer from a different network?
May the Source be with you!
haselyn
#4 21.06.2009 01:03
This affects Firefox, IE8, Opera 10.

I had someone else from another country test it as well, shows no controls there either.
robofreak111
#5 21.06.2009 01:36
Im using IE8 right nioow and it seems to be working just fine
Kingsley
#6 21.06.2009 02:20
3 countries, 3x problem only with IE7+8
haselyn
#7 21.06.2009 03:06
Local:
<head>
<script type="text/javascript" src="js/jquery.js"></script><script type="text/javascript" src="js/base.js"></script><script type="text/javascript">

Remote:
<head>
<script type="text/javascript" src="js/base.js"></script><script type="text/javascript">

This is after uploading all the root files, js directory, system directory and reuploading the markitup plugin. Anyone know which file calls the jQuery.js file? Because I'm guessing that's where the problem lies.

OK, solved it.

For whatever reason there are three options of 'enable jquery' in the settings for the site.

Unfortunately, you can only select one of the 6 options, and only one of the three 'yes' options seems to work... Really weird. It works now though :)
Отредактировано: haselyn (21.06.2009 03:11, 13 лет назад)
Trustmaster
#8 21.06.2009 13:43
Probably something wrong happened when you were importing SQL scripts, so that 5 extra instances of that option emerged.
May the Source be with you!