Cotonti / Open Source PHP Content Management FrameworkContent Management Framework

Cotonti Siena 0.9.20 released

News / Announcements / Cotonti Siena 0.9.20 released

We glad to announce new Cotonti version 0.9.20 with PHP 8.0 support

Whats new:

  • Dropped support of PHP 5.3, now minimal requirements is PHP 5.4
  • Compatibility with PHP 8.0. We are waiting for the Htmlpurifier update to implement compatibility with PHP 8.1
  • CKEditor updated to version 4.19.1
  • Htmlpurifier updated to version 4.14.0
  • Installer errors have been fixed
  • Improved work with MySQL (InnoDB engine instead of MyISAM, and utf8mb4 charset)
  • Improved email sending
  • Lots of fixes and improvements

For more detailed info see:

Commits list

Closed 0.9.20 issues

 

Learn more, download and upgrade for more stability!


1. Denisbox  2022-08-26 20:52

Не устанавливается. После второго экрана установки (там где идёт подключение к БД) выходит ошибка. Побовал на старом OpenServer c PHP 7.023 и на новом с PHP8. У всех всё работает?

2. Alex300  2022-08-27 05:52

Problem with support 'utf8m4' charset by old MySQL versions. It is solved. see https://github.com/Cotonti/Cotonti/issues/1658
---
Проблема в поддержке старыми версиями MySQL кодировки 'utf8m4'. Решено. см. https://github.com/Cotonti/Cotonti/issues/1658

 

3. Denisbox  2022-08-27 07:24

Спасибо! Сейчас попробую!

4. Denisbox  2022-08-27 21:49

Всё заработало! Спасибо!

В связи с этим сразу пару вопросов:

1) Может быть данное исправление добавить по умолчанию? Сейчас новый пользователь просто будет скачивать сборку и получив ошибку, скорее всего больше устанавливать Cotonti не будет.

2) Многие дополнительные расширения с сайта уже не работают на PHP 7.2, а сборка 0.9.20 предполагает работу на PHP8. В связи с чем может пора уже переименовывать Siena, так как в будущем возникнет дикая путаница?

Извините, что умничаю, но это логичные вопросы.

P.S. У форума проблемы с созданием новых тем, по этому и пишу в комментарии.

5. Alex300  2022-08-29 05:21

Там проблема возникает у тех, кто использует php версии ниже 5.6 и/или MySQL версии ниже 5.7. Это уже достаточно старое ПО, так что вероятность того, что кто то нарвется на ошибку минимальна. Я и сам не тестировал его на таком ПО пока не сообщили о проблеме. В следующий релиз это уже войдет.

Сейчас нет проблем у форума ))). Если же все таки есть - опишите как воспроизвести - поправлю.

На форуме, думаю надо завести тему для запросов обновлений расширений для работы под php 8.1

 

Если есть ошибки в расширения "из коробки", смело создавайте issue на гитхабе с описанием ошибки и как ее воспроизвести.

Total: 5, on page: 5

Only registered users can post new comments