Cotonti / Open Source PHP Content Management FrameworkContent Management Framework

Forums / Cotonti / Support / Can not add, edit or publish pages.

Uploaded a new site to a different host

foxhound
#1 2013-02-24 14:37


Donator
Thanked: 2 times

I have been working on a new website (latest Sienna version) which I have been building on one of my own dedicated servers. The site will however be hosted on a different server so yesterday I transferred all files (website + database) to this new host. Everything is there now, I can see the website and I can access everything in the admin panel so all seems to work fine.

However, for some unknown reason I can not add/edit/publish pages. When I edit an existing page and set it to publish or submit for approval I get an error message "Error
An error occured, maybe wrong url?"
When I try to add a new page I get a message telling me "access denied(#930), you are not allowed to do this. Redirecting...".

So, I spend a few hours trying to figure out what was wrong and went through the config file and all settings in the admin panel. Than I checked the database to see if maybe some old url (of the old server) was in the DB causing a conflict. Nothing is wrong. All is how it should be as far as I can tell.
So, this morning I figured I should make a new test site on this new host and see if at least things work there...........guess what. On a clean new website I get the exact same issues.

There is one thing I have noticed though.........on this new host the index.php part in the url is missing.
For example on my own dedicated an url of a page I am editing or viewing looks like this:
- Link to a page: xxxxxxxx/xxxxxxx/steigerh/index.php?e=page&c=infoboxes&al=test
- Link when editng that page: xxxxxxxx/xxxxxxx/steigerh/index.php?e=page&m=edit&id=2

On the new host
- Link to a page: xxxxxxxx/testers/cotonti_testsite/?e=page&c=articles&al=Onze-steigerhout-producten-bestellen#.USokZlfv5co
- Link when editing that page: xxxxxxxx/testers/cotonti_testsite/?e=page&m=edit&id=3

See how the index.php part completely vanished? There are no htaccess settings which remove the index.php from an url. The htaccess file in the root of the site on both servers is empty.

I am completely lost. If the issue is with the host I would not know what it could be but it is the first time I try a Sienna site on it. I am already running a Genoa site on it.
 
 
** fixed typo

This post was edited by foxhound (2013-02-24 17:10, 2 years ago)
tensh
#2 2013-02-24 16:44


Contributors
Thanked: 9 times

If there's a .htaccess that is higher in the folder hierarchy (in place of xxxx or testers), check it out as well. The htaccess might be propagating to cotonti_testsite as well.

Also, manually change in database the url settings to "none" (in case the site tries to load something from urltrans.dat).

That's what comes to my mind...

foxhound
#3 2013-02-24 17:07


Donator
Thanked: 2 times

Amazing! Thank you very much :)
Indeed I had an index.php redirect in the .htaccess of the main website to prevent duplicate content. I forgot about that completely and completely did not think about checking it. I only checked all htaccess files in this test site folder, not those up in the main site. blush

Sigh, sometimes I cause myself so much unneeded work and waist of time .......  Ah well, I hope my stupidity and asking that will help others in the future.

tensh
#4 2013-02-25 08:09


Contributors
Thanked: 9 times

No problem, I'm glad I could help.

(It just happened that three days ago I had a similar problem :P)